Update des CMS 2016

Michael

Michael

Admin
Beiträge
13.626
Wohnort
Lindhorst
In der Hoffnung jetzt alle Probleme gelöst zu haben werde ich heute Nacht das CMS updaten. Das bedeutet, dass der Bereich um die fertiggestellten Küchen und sonstiger Themenbereiche für mehrere Stunden offline sein wird. Auf den Forenbetrieb hier wird es keinerlei Auswirkungen haben - Das Forum bleibt online. Besucher der Startseite erhalten einen Hinweis auf das geöffnete Forum.

Morgen kann es (wird es wahrscheinlich auch) zu Problemen beim Login kommen. Auch das betrifft nur das CMS, in welchem man beim Login im Forum eigentlich automatisch mit angemeldet sein soll. Eigentlich....

Wichtig ist es bei Problemen vorerst den kompletten Browsercache einschließlich der Cookies zu löschen. Die Sessions werden alle neu generiert und ältere Cookies können den Login in beiden Systemen verhindern.

Es wird auch alles in neuem leicht verändertem Glanz erscheinen. In einem Zuge habe ich gleich das Template modernisiert. Viele kleine noch erforderliche Änderungen erfolgen dann im Lauf der Zeit im Livebetrieb, weil es offline einfach nicht zu testen ist.

Für alle evtl. auftretenden Unannehmlichkeiten entschuldige ich mich vorab und hoffe auf euer Verständnis für die Maßnahme. Eigentlich sagt man ja: "Never change a running system". Aber in diesem Fall wird es schon aus Sicherheitsgründen langsam Zeit für einen Relaunch des Systems.

Bis dahin wünsche ich eine geruhsame Nacht - Ich halte die Stellung. :nageln:

Probleme bitte wie immer in diesem Thema posten. Ich kümmer mich..... :read:
 
KerstinB

KerstinB

Administratorin
Admin
Beiträge
47.860
Schon alles durch? ... Gerade eben konnte ich fertiggestellte Küchen noch problemlos anwählen. Ansonsten
proxy.php?image=http%3A%2F%2Fwww.cosgan.de%2Fimages%2Fmore%2Fschilder%2F119.gif&hash=bb8f8ef7977047337fd0a16f4a64bee0
 
KerstinB

KerstinB

Administratorin
Admin
Beiträge
47.860
Na denn .. sehr schön, aber erste Fehlermeldung ;-)

Ich habe von dieser Threadseite einfach planunten rechts "fertiggestellte Küchen" angewählt und lande im CMS ... unangemeldet. Dort dann oben rechts im "Quermenü" Login angewählt.

Ohne Cookies Löschen, allerdings Cache gelöscht:
Nach Anwahl Login lande ich in der Forenübersicht vom Forum.

Mit Cookies Löschen und Cache gelöscht:
Login-Seite CMS kommt, Login wird auch angenommen, danach lande ich wiederum in der Forenübersicht

Dies passiert auch, wenn ich Login nicht vom Bereich "fertiggestellte Küchen", sondern auch von der Startseite aus anwähle.
 
Michael

Michael

Admin
Beiträge
13.626
Wohnort
Lindhorst
Das ist das Cookie-Problem.
Der Login-Button im CMS erscheint wenn man dort nicht eingeloggt ist. Drückt man drauf landet man im Forum auf der Login-Seite. Ist man im Forum allerdings bereits angemeldet (obwohl im CMS nicht) gibt es keine Login-Seite und man landet in der Forenübersicht.

Es gibt also nach nach erfolgreichem Login immer einen redirect ins Forum. Das soll auch so sein und das war auch vorher so.
 
KerstinB

KerstinB

Administratorin
Admin
Beiträge
47.860
Ups, hatte den falschen Plan gesehen ... da waren mal irgendwo 131 cm ... allerdings mit Wandstärke *kiss* ... 120 cm ..nee, da hast du leider Recht, das geht nicht.
 
Nice-nofret

Nice-nofret

Moderatorin
Moderator
Beiträge
18.826
Wohnort
Schweiz
... falls Du mal ein Leierkasten-Smiley findest - DAS fehlt in unserer Sammlung
 
Michael

Michael

Admin
Beiträge
13.626
Wohnort
Lindhorst
Also irgendetwas stimmt noch nicht und der Server generiert Fehlermeldungen.

Könnt ihr mir mal helfen und euch einige Mal ausloggen und wieder einloggen?
Das geht momentan nur hier im Forum. Das Login-Modul der Startseite habe ich deaktiviert weil ich glaube, dass es den Fehler verursacht.
 
menorca

menorca

Moderatorin
Moderator
Beiträge
15.754
Wohnort
München
Mir scheint alles normal zu funktionieren, anmelden - abmelden - grünes Kreuzerl - ich komme überall hin - auch anmelden über die Startseite
 
Michael

Michael

Admin
Beiträge
13.626
Wohnort
Lindhorst
Das klingt gut und es sind auch keine Fehlermeldungen mehr da.
Anmelden von der Startseite sollte nicht mehr gehen. Der Login-Link leitet hier ins Forum von wo aus die Anmeldung erfolgen soll.

Jetzt habe ich nur noch ein kleines Problem bei Neuregistrierungen. Neue Mitglieder müssen sich nämlich nach der Aktivierung erst einmal ausloggen und wieder einloggen um im CMS angemeldet zu sein.

Das kriege ich aber auch noch irgendwie hin...
 
menorca

menorca

Moderatorin
Moderator
Beiträge
15.754
Wohnort
München
Stimmt, wenn ich mich von der Startseite aus anmelde, sieht die Seite zwar anders aus als von der Forumsseite aus, aber in der Browserzeile steht dann trotzdem kuechen-forum.de/forum
 
Michael

Michael

Admin
Beiträge
13.626
Wohnort
Lindhorst
Das ist die Login Seite im Forum die z.B. auch erscheint wenn du ein falsches Passwort eingegeben hast.
Dorthin verlinke ich von der Startseite damit explizit aus dem Forum heraus eingeloggt werden kann.

Es gibt Probleme wenn man nach dem Login in beiden Systemen angemeldet ist und danach länger als 30 Minuten im Forum aktiv ist. Dann wird man nämlich aus dem CMS automatisch ausgeloggt (Sitzungslänge 30 Minuten) und kann sich dann aus dem Forum nicht mehr ausloggen.

Deswegen habe ich die Sitzungslänge im CMS jetzt auf 3000 Minuten gestellt. Damit hoffe ich das Problem umschiffen zu können.
 
KerstinB

KerstinB

Administratorin
Admin
Beiträge
47.860
D. h., alle ca. 4 Tage muss ich mich einmal im CMS bewegen, damit meine Anmeldung dort erhalten bleibt? Eben war ich nämlich dort abgemeldet (bei mir haben wohl die 3000 Minuten noch nicht gewirkt ;-)). Ich melde mich ja eigentlich nie ab hier im Küchenforum, mußte gerade erstmal den Button suchen ;-). Habe das jetzt gemacht und mich wieder von der Startseite angemeldet. Ich werde beobachten, wie sich deine Änderung auswirkt.
 
isabella

isabella

Mitglied
Beiträge
7.494
Der als Makro hinterlegte Link zum Lexikonbegriff Ullaschrank funktioniert nicht mehr, weil jetzt im Lexikon die Versionsnummer in der URL hinterlegt ist... das ist nicht so gut, da sich damit die URL bei jeder Überarbeitung der Lexikonseite ändert...
 
Michael

Michael

Admin
Beiträge
13.626
Wohnort
Lindhorst
D. h., alle ca. 4 Tage muss ich mich einmal im CMS bewegen, damit meine Anmeldung dort erhalten bleibt?
Eigentlich nicht. Die Session im CMS soll halt nicht beendet werden während man hier noch aktiv ist.
Die Sessionlänge im Forum ist 30 Minuten lang. Wer 30 Minuten inaktiv ist wird automatisch abgemeldet und somit auch im CMS. Wenn man den Haken bei "angemeldet bleiben" setzt (Jetzt standardmäßig aktiv) wird man trotzdem abgemeldet, beim nächsten Besuch aber automatisch wieder angemeldet. Und somit auch im CMS.
Das ist der Hintergrund.
 

Mitglieder online

  • Tichu78
  • TomiTom
  • Snow
  • XLII
  • Conny
  • moebelprofis
  • olafdruemmer
  • Captain Obvious
  • thermoman
  • mozart
  • elnino
  • angeliter
  • Rebecca83
  • Lisa90
  • johnnyger
  • Shania
  • Michael
  • ClaudiaM

Neff Spezial

Blum Zonenplaner